
Simulácia prúdenia okolo profilu krídla – 2D 
 
Na tomto príklade si ukážeme vytvorenie profilu krídla, vytvorenie štruktúrovanej siete a  numerickú 

simuláciu prúdenia okolo profilu krídla NACA 0021 s dĺžkou tetivy 0,5m,  pri uhloch nábehu , 
pri rýchlosti prúdu 20 m/s.  Sledovať budeme základné aerodynamické parametre – koeficient vztlaku 
a odporu. 

 
Náčrt úlohy 

 

Vytvorenie geometrie 
Otvoríme si ANSYS postupom už vyššie uvedeným. Spustíme ANSYS Workbench. Dvojklikom na Fluid 
Flow (Fluent) sa v pracovnom prostredí WB zobrazí tabuľka. Dvojklikom na Geometry sa spustí DM. 
Ako jednotky vyberieme metre. Ak nám program túto možnosť nedáva, ideme do roletového menu 
Unit a zaškrtneme metre. Vyberieme si 1. XYPlane, 2. kolmý pohľad na rovinu. 
Potrebujeme si najprv vytvoriť dátový súbor s koordinátami profilu (x, y, z - súradnice). Tento súbor 
načítame do DM a vytvoríme 3D krivku, ktorá bude reprezentovať profil krídla. Zadáme do 
internetového vyhľadávača napr. výraz „naca airfoil calculator“  a otvoríme si nasledovný odkaz viď. 
Obr. XXX 
 

 
 

 
Otvorí sa nám NACA generátor, kde si vygenerujeme súradnice profilu. Do poľa pre Max Camber (%) 
napíšeme 0. Do poľa pre Max camber position (%) tiež dáme 0. Do poľa pre Thickness (%) napíšeme 
21. Takto máme nadefinovaný profil 0021. Number of points dáme 200. Zaškrtneme Cosine spacing aj 
Close Trailing edge. Klikneme na Plot. Vpravo v okne Dat file sa nám vytvoria súradnice požadovaného 
súboru. 
 

 
 

 



Označíme všetky údaje v okne Dat file a skopírujeme ich. Otvoríme Poznámkový blok (Notepad) 
a vložíme ich. Vymažeme prvý riadok, kde sú informácie o profile - NACA 0021 Airfoil M=0.0% P=0.0% 
T=21.0%. Súbor bude vyzerať nasledovne, viď. Obr. XXX.  
 

 
 

 
Tento súbor uložíme ako napr. NACA0021.txt a zavrieme. Otvoríme si program MS Excel, vyhľadáme 
uložený textový súbor a otvoríme ho. Pri otváraní v okne Oddeľovače (Delimiters) zaškrtneme Medzera 
(Space). Vložíme dva riadky a jeden stĺpec.  Na pozíciu A2 napíšeme #group, B2 #point, C2 #x_cord, 
D2 #y_cord, E2 #z_cord. Do stĺpca group vložíme číslo 1. Do stĺpca point dáme poradie od 1 do 200. 
Posledné číslo po 200 bude 0. Do stĺpca #z_cord dame 0. Výsledný súbor by mal vyzerať nasledovne, 
viď obr. XXX 
 

  
  

 
Súbor uložíme ako textový. V tejto chvíli sa môžeme vrátiť k programu Design Modeler. Z roletového 
menu vyberieme Concept>3D Curve.  
 
 

 
 

 
V okne Details View ľavým tlačidlom klikneme na žltým podsvietené Not selected pri Coordinates File 
a načítame uložený textový súbor NACA0021.txt. Po načítaní sa nám zobrazí  krivka profilu 
svetlomodrou farbou. Klikneme na tlačidlo Generate a farba profilu sa zmení na sivú. Náš profil má 



dĺžku tetivy 1 m. Vzhľadom k tomu, že v zadaní úlohy máme určenú dĺžku profilu 0,5 m, je potrebné 
tento adekvátne zmenšiť. 
Z roletového menu vyberáme Create>Body Transformation>Scale viď. Obr. XXX. 

 
 

 
Priložíme kurzor myši na krivku profilu a ľavým tlačidlom na ňu klikneme. Zmení sa farba na žltú. V okne 
Details View ľavým tlačidlom klikneme na Apply pri Bodies.  
 
 
 

 
 

 
Do políčka ku Global Scaling Factor namiesto 1, napíšeme 0,5, čím zabezpečíme zmenšenie celého 
profilu na polovicu. Klikneme na Generate. Nasledujúci krok je vytvorenie plochy z krivky, čo urobíme 
nasledovne. Z roletového menu vyberáme Concept>Surface From Edges. 
 

 
 

 
Priložíme kurzor myši na krivku profilu a ľavým tlačidlom na ňu klikneme. Zmení sa farba na zelenú. 
V okne Details View ľavým tlačidlom klikneme na Apply pri Edges.  



 
 

 
Klikneme na tlačidlo Generate a vytvorí sa nám šedá plocha profilu krídla viď obr.XXX.  
 

 
 

Nasleduje vytvorenie tzv. domény, čiže priestoru prúdenia vzduchu.  Aby sa nám dve plochy, tj. priestor 
prúdenia a plocha profilu vzájomne neovplyvňovali, použijeme príkaz z roletového menu Tools>Freeze. 
Vytvoríme si teraz novú rovinu s počiatkom súradnicového systém, ktorý bude v odtokovom bode 
profilu krídla. To zrealizujme tak, že  klikneme na ikonu tlačidla New Plane.  
 

 
 

 
V okne Details View pri Transform1 nastavíme Offset Global X a pri políčku FD1, Value 1 napíšeme 0,5. 
Týmto sme vytvorili novú rovinu so súradnicovým systémom, ktorý je oproti pôvodnému posunutý 
v smere osi x o 0,5 m. Potvrdiť to je potrebné kliknutím na tlačidlo Generate. 
 
 

 



 

 
V Tree Outline klikneme najprv na novovytvorenú rovinu Plane 5 a potom klikneme na tlačidlo New 
Sketch. 
 

 
 

 
Prepneme sa na záložku Sketching a vyberiem si z ponuky kreslenia Arc by Center. 
 
 
 
 

 
 

 
 
Nastavíme sa do stredu súradnicového systému klikneme ľavým tlačidlom myši a ťaháme kurzor myši 
po osi y nahor. Popri osi sa nám zobrazuje písmeno C a vidíme tvar kružnice.  



 
 

 
 
Odklikneme na osi y na ľubovoľnom mieste a ťaháme myšku doľava a nadol.  

 
 

 
 
Dostaneme sa na os y pod súradnicovým systémom, znova sa objaví písmeno C a  odklikneme 
a vytvoríme tak poloblúk.   



 
 

 
Prepneme sa zo záložky Draw do záložky Dimensions. Vyberieme Radius a klikneme na poloblúk. 
Klikneme ľubovoľne do priestoru kreslenia. V okne Details View dáme polomer 6 m pri Dimensions 1, 
R1. Prepneme sa do záložky Draw  a zvolíme Rectangle by 3 Points. Kurzorom myši sa priblížime 
k hornému bodu na osi y, pokiaľ sa objaví písmeno P, odklikneme. Ťaháme kurzor k dolnému bodu na 
osi y pokiaľ sa objaví písmeno P, odklikneme. Ťaháme kurzor doprava a  ľubovoľne v priestore kreslenia 
odklikneme. Nakreslený obrázok vyzerá nasledovne.  
 

 
 

 
 
Ešte nie je zakótovaná vzdialenosť medzi osou y a vertikálou na pravej strane. Prepneme sa zo záložky 
Draw do záložky Dimensions. Vyberáme Horizontal a klikneme na os y a vertikálu na pravej strane. 
Odklikneme kdekoľvek v priestore kreslenia. Zadáme dĺžku 6m.  



 
 

 
Odstránime pre nás v tejto chvíli vertikálne čiary, ktoré sa prekrývajú s osou y. Prepneme sa zo záložky 
Dimensions do záložky Modify. Zvolíme Trim a klikneme na vrchnú a na spodnú čiaru, ktorá prekrýva 
os y. Tieto čiary sa stratia. Môžeme teraz vytvoriť plochu prúdenia. Z roletového menu vyberáme 
Concept>Surface from Sketches. V stromovom menu Tree Outline klikneme na Sketch ktorým sme 
vytvorili priestor prúdenia a klikneme v Detail View na Apply pri Base Objects.  

 
 

 
Klikneme na tlačidlo Generate. Mali by sme mať nasledovný obrázok 



 
 

 
V nasledujúcom kroku urobíme prienik  dvoch plôch a  z domény vlastne vyrežeme plochu profilu. 
Prepneme sa na záložku Modeling. Z roletového menu vyberáme Create>Boolean a v Details View 
klikneme vedľa poľa Operation a vyberieme Subtract.  
 

 
 

Klikneme do poľa vedľa Target Bodies a vyberieme plochu domény. Klikneme na Apply. Klikneme do 
poľa vedľa Tool Bodies a vyberieme plochu profilu. Klikneme na Apply a na Generate. Výsledný obrázok 
by mal vyzerať nasledovne.  
 

 



 

 
Nasleduje posledný krok v tvorbe geometrie, ktorým je rozdelenie domény na kvadranty. Toto nám 
uľahčí vytvorenie mriežky. Zvolíme vytvorenú rovinu v Tree Outline  a klikneme na ikonu tlačidla New 
Sketch. Prepneme sa na záložku Sketching, kde sa otvoria nástroje pre 2D kreslenie. V menu kreslenia 
vyberieme príkaz priamka Line. Nakreslíme  na osiach jednu vodorovnú a zvislú čiaru. Priblížime sa 
kurzorom k osi x, kde táto pretína poloblúk. Pri osi je písmeno C a poloblúk zmení farbu na červenú. 
Klikneme a ťaháme čiaru cez doménu po osi x k pravej zvislej čiare, pokiaľ táto zmení farbu na červenú. 
Odklikneme. 

 
 

 
To isté urobíme zhora nadol. Tu je to jednoduchšie, lebo na osi y máme horný aj dolný bod, kde os 
pretína doménu. Výsledný obrázok má vyzerať nasledovne. 
 
 
 

 
 

 
Prepneme sa na záložku Modeling a z roletového menu vyberáme Concept>Lines from Sketches. 
Vyberiem Sketch kde sú vytvorené 2 čiary a v Details View klikneme na Apply pri Base Objects. Klikneme 
na tlačidlo Generate. Urobíme projekciu týchto čiar do domény. Vyberieme z roletového menu 



Tools>Projection. Klikneme pomocou pomocou CTRL na 4 čiary a v  Details View stlačíme Apply pri 
Edges.  

 
 

Označíme doménu a v Details View stlačíme Apply pri Target. Klikneme na Generate. Keď klikneme na 
doménu tak ju máme rozdelenú na kvadranty viď. Obr XXX.  

 
 

 
V Tree Outline vidíme že máme vytvorené 2 Line Body a 1 Surface Body. Nám do ďalšej práce postačuje 
doména (surface body), prebytočné časti odstránime. Vyberáme z roletového menu 
Create>Delete>Body Delete. Z Tree Outline vyberiem obidve Line Body (pomocou CTRL) a stlačíme 
tlačidlo Apply pri Bodies v Detail View. Generate. Týmto je časť tvorby geometria ukončená.  
 

Vytvorenie výpočtovej siete 
 



V prostredí ANSYS Workbench dvojklikom na Mesh sa spustíme program Meshing. Začneme príkazom 
na vytvorenie štruktúrovanej siete. V okne Outline klikneme na Mesh, vyvoláme kontextovú ponuku, 
vyberieme Insert>Mapped Face Meshing, viď (obr. XXX) 
 

 
 

 
Vyberieme všetky kvadranty domény (CTRL) a klikneme na tlačidlo Apply pri poli Geometry v Details 
of. Doména je sfarbená na modro. V tejto chvíli ak by sme nechali vygenerovať sieť, bola by 
štruktúrovaná ale podľa algoritmu softvéru a nám nemusí vyhovovať. Z toho dôvodu my určíme počet 
buniek na hranách kvadrantov aj zahustenie siete smerom k profilu.  
Obdobným spôsobom ako je vyššie uvedené v okne Outline klikneme na Mesh, vyvoláme kontextovú 
ponuku, vyberieme Insert>Sizing. Vyberieme 4 hrany podľa obrázka a klikneme na tlačidlo Apply pri 
poli Geometry v Details of. (Tento postup môžeme robiť aj pre každú hranu osobitne, čiže nemusíme 
naraz 4). V okne Details of pri poli Type vyberieme Number of Divisions. Znamená to, že sme stanovili, 
že hrana bude rozdelená na určitý počet úsekov (počet buniek na hrane). Vedľa poľa Number of 
Divisions dáme 50. Vedľa poľa Behavior nastavíme Hard. Znamená to, že to bude presne určený počet 
buniek. Ak by sme ponechali Soft, tak softvér to berie ako približnú hodnotu počtu buniek.  V poli pri 
Bias Type zvolíme ------ --- - -. Znamená to zhustenie buniek na jedným smerom. Do poľa vedľa Bias 
Factor dáme 150. Znamená to nárast (pokles) veľkosti bunky na hrane s  uvedeným faktorom. 
 

 
 

 
Postup opakujeme, čiže v okne Outline klikneme na Mesh, vyvoláme kontextovú ponuku, vyberieme 
Insert>Sizing a vyberieme ďalšie hrany podľa obrázka a klikneme na tlačidlo Apply pri poli Geometry 
v Details of. Nastavenie rovnaké až na Bias Type. Ten bude - - --- -----.  
 



 
 

 
Ostali nám ešte hrany poloblúka, takže opäť v okne Outline klikneme na Mesh, vyvoláme kontextovú 
ponuku, vyberieme Insert>Sizing a vyberieme hrany poloblúka. Vedľa poľa Number of Divisions dáme 
100. Behavior – Hard. Tentokrát nerobíme zahustenie, čiže Bias Type – No Bias.  

 
 

 
Odklikneme Generate Mesh a po kliknutí na Mesh v okne Outline by sme mali vidieť nasledovnú sieť.  
 



 
 

 
Sieť je vytvorená a je potrebné určiť okrajové podmienky. Klikneme postupne na obidve hrany 
poloblúka, spodnú aj hornú vodorovnú čiaru a vyvoláme kontextovú ponuku. Odtiaľ vyberieme Create 
Named Selection.  
 

 
 

 
Tadiaľ bude prúd vzduchu vchádzať do domény stanovenou rýchlosťou, čiže to bude okrajová 
podmienka – rýchlostný vstup. Do poľa pre Selection Name píšeme Velocity Inlet. Postup opakujeme.  
Dve zvislé čiary na konci domény označíme ako tlakový výstup, čiže napíšeme do poľa pre Selection 
Name – Pressure Outlet. Ďalej si obdobným spôsobom označíme spodnú hranu profilu ako wall_PS. PS 
bude znamenať tlakovú hranu (Pressure Side). Hornú časť profilu označíme ako wall_SS, čo znamená 
sacia hrana (Suction Side). Sieť máme vytvorenú a sme pripravená na nastavenie a spustenie simulácií.  
V tejto chvíli máme na výber či sa vrátime do ANSYS Workbench a  dvojklikom na Setup (predtým je 
potrebné kliknúť na Update Project), alebo vyexportovať súbor *.msh a načítať ho do programu ANSYS 
Fluent.  
Na základe skúseností odporúčam druhu možnosť a to v programe Meshing, vyberieme z roletového 
menu File>Export. Súbor si ľubovoľne pomenujeme ale uložíme ho ako typ: FLUENT Input Files (*.msh). 
 



 
 

 

Nastavenie a spustenie simulácie 
Otvoríme si program ANSYS Fluent. V otváracom okne označíme Dimension – 2D  a pri Options – 
Double Precision. 

 
 

 
Z roletového menu vyberáme príkaz File>Read>Mesh a načítame vytvorený súbor. 
 

 
 

 
Nastavíme teraz simuláciu. Klikneme na General pod Solution Setup. Tu ponecháme všetky nastavenia 
ako sú. Solver (riešič) bude Pressure Based. Budeme riešiť stacionárnu úlohu s absolútnou formuláciou 
rýchlosti. 2D priestor je Planar (rovinný).  

 
 

 



Nastavíme sa na Models a dvojklikom na Viscous sa nám zobrazia modely prúdenia. Vyberieme si 
model k-omega a v poli k-omega Model vyberieme SST. Odklikneme OK.  

  
  

 
Nastavíme sa na Materials. Vzhľadom k tomu, že je ako Fluid prednastavený vzduch (Air) 
nepotrebujeme nič nastavovať a nič nebudeme meniť ani v Cell Zone Conditions. Kliknutím na 
Boundary Conditions sa nám v okne Zone zobrazia okrajové podmienky, ktoré sme definovali v ešte 
v programe Meshing. Je vhodné skontrolovať či pod Type je vysvietená požadovaná okrajová 
podmienka. Ak to tak nie je, tak je to tu potrebné zmeniť, kliknutím a vybratím správnej. Čiže velocity 
inlet – velocity inlet, pressure outlet – pressure outlet, wall_ps – wall  a wall_ps – wall. Okrem 
definovaných okrajových podmienok sa nám objavili ďalšie okrajové podmienky, ktoré vyjadrujú 
interiér, čiže vnútro priestoru prúdenia a nijakým spôsobom neovplyvňujú prúdenie. Interior-
surface_body je vnútro domény a surface_body sú štyri priamky, ktorými sme doménu delili na 
kvadranty.  
 

 
 

Klikneme na velocity inlet a stlačíme Edit....  Otvorí sa okno Velocity Inlet. V tejto úlohe budem pracovať 
len s možnosťami na záložke Momentum. Klikneme na roletové menu pri Velocity Specification Method 
a vyberieme Magnitude and Direction. To znamená, že stanovíme rýchlosť a smer prúdenia na profil. 
Do okna Velocity Magnitude (m/s) napíšeme 20. Supersonic/Initial Gauge Pressure (pascal) sa nás 
netýka, pretože neriešime stlačiteľnosť. Smer prúdenia na profil, teda uhol nábehu zadefinujeme 
pomocou nasledovných dvoch okien. Do okna X-Component of Flow Direction vpíšeme kosínus uhla 
nábehu. V našom prípade je uhol nábehu 0°, teda vpíšeme 1, pretože cos0°=1. Do okna Y-Component 



of Flow Direction vpíšeme sínus uhla nábehu. V našom prípade je uhol nábehu 0°, teda vpíšeme 0, 
pretože sin0°=0. 
V sekcii Turbulence je ešte potrebné nastaviť Specification Method. Klikneme na rolovacie menu 
a vyberieme Intensity and Hydraulic Diameter. Intenzita turbulencia sa pri modelovaní prúdenia na 
veterných zariadeniach stanovuje maximálne na 15%. V našom prípade môžeme ponechať 5%. 
Hydraulic diameter (hydraulický priemer) pri 2D simuláciách, je rovný šírke domény, čo je u nás 12 m. 
Okrajovú podmienku rýchlostného vstupu máme nastavenú, klikneme tlačidlo OK.  
  

 
 

Klikneme na pressure outlet a stlačíme Edit....  V sekcii Turbulence je takisto potrebné nastaviť 
Specification Method. Klikneme na rolovacie menu a vyberieme Intensity and Hydraulic Diameter.  
Zadáme rovnaké hodnoty ako na vstupe. Backflow Turbulent Intensity 5% a Backflow Hydraulic 
diameter 12 m. OK.  
Položku Dynamic Mesh nebudeme nastavovať, pretože nepracujeme s pohyblivou alebo deformujúcou 
sa sieťou.  
Klikneme na Reference Values. Do okna Area (m2), vpíšeme dĺžku tetivy, čiže 0,5. Ak by sme mali 3D 
krídlo, tak dávame plochu krídla. Do okna Velocity  (m/s) dáme rýchlosť prúdenia, čiže 20.  
Pod Solution klikneme na Solution Methods. Nastavenia urobíme podľa obrázku XXX. Pressure Velocity 
Coupling: Scheme – SIMPLE, Spatial Discretization: Gradient – Least Squares Cell Based, Pressure – 
Second Order, Momentum – Second Order Upwind, Turbulent Kinetic Energy – Second Order Upwind, 
Specific Dissipation Rate – Second Order Upwind.  



 
 

 
Na položke Solution Controls nenastavujeme nič. Klikneme na Monitors, nastavíme sa v okne Residuals, 
Statistic and Force Monitors na Residuals – Print, Plot a klikneme na tlačidlo Edit.  Otvorí sa nám okno 
Residuals Monitor, kde ponecháme zaškrtnuté Print to Console a Plot a v rolovacom okne Convergence 
Criterion nastavíme none. Síce sa udáva, že pri hodnotách rezíduí pod 0,001 sú výsledky konvergované, 
ale osobná skúsenosť ukazuje, že je potrebné sledovať, kedy sa ustália sily pôsobiace na objekt. Z toho 
dôvodu sme nezadali konvergenčné kritériá,  pri ktorých by sa výpočet prerušil. Pokračujeme kliknutím 
na tlačidlo OK.  

 
 

 
Aby sme mohli vidieť ustálenie síl pôsobiacich na profil v okne Residuals, Statistic and Force Monitors 
klikneme na rolovacie okno Create a odklikneme Drag…. Týmto sa nám otvorí okno Drag Monitor. 
V okne Wall Zones vyberieme wall_ps aj wall_ss a v okne Options zaškrtneme Plot a vo Window dáme 
2. Týmto sme zadefinovali, že v okne 2 budeme sledovať pôsobenie sily v smere osi x na profil krídla.  



 
 

 
Tento postup zopakujeme s tým, že v okne Residuals, Statistic and Force Monitors klikneme na 
rolovacie okno Create a odklikneme Lift. Otvorí sa okno Lift Monitor. V okne Wall Zones vyberieme 
wall_ps aj wall_ss a v okne Options zaškrtneme Plot a vo Window dáme 3. Kliknem na tlačidlo OK. 
Týmto sme zadefinovali, že v okne 3 budeme sledovať pôsobenie sily v smere osi y na profil krídla. 
Nastavíme sa na Solution Initialization a klikneme na tlačidlo Initialize. Týmto sa nám simulácia 
inicializuje. Ďalšiu položku Calculation Activities preskočíme, pretože nebudeme nastavovať 
automatické ukladanie. Ostáva len spustenie simulácie a to tak, že klikneme na položku Run Calculation 
a v okne Number of Iterations nastavíme predpokladaný počet iterácií. Dajme 100 a klikneme na 
tlačidlo Calculate.  Po ukončení výpočtu sa pozrime na priebeh iterácií. Mali by sme mať nasledovné 
výsledky. 

 
Z uvedených priebehov rezíduí a priebehu odporu a vztlaku, by sme mohli nadobudnúť dojem, že je 
výpočet konvergovaný. Rezíduá klesli pod 10-3 a priebehy odporu a vztlaku sú ustálené. Nie je to však 
tak.  
Nastavíme sa na položku Monitors pod Solution a v okne Residuals, Statistic and Force Monitors sa 
nastavíme na cd-1 –Plot. Klikneme na tlačidlo Edit. Klikneme na tlačidlo Clear. Zobrazí sa okno s otázkou 
Ok to discard Drag monitoring data? Potvrdíme Yes. OK. Nastavíme na cl-1 –Plot. Klikneme na tlačidlo 
Edit. Klikneme na tlačidlo Clear. Zobrazí sa okno s otázkou Ok to discard Lift monitoring data? 
Potvrdíme Yes. OK. Týmto sme vymazali priebehy odporu a vztlaku. To sme urobili preto, lebo 
v skutočnosti sa tieto priebehy naďalej pohybujú, ale my to vzhľadom na veľké úvodné výkyvy 
nevidíme. 
Nastavíme sa na Run Calculation. Do okna Number of Iteration dáme 1000 a klikneme na tlačidlo 
Calculate. Po ukončení výpočtu sa znova pozrieme na priebehy.  

   
   



   
   

 
Rezíduá sú pod 10-8 a priebehy odporu a vztlaku sa môžu hýbať na úrovni ôsmeho desatinného miesta. 
Z toho dôvodu budeme považovať výpočet za konvergovaný a  môžeme sa pozrieť na dosiahnuté 
výsledky.  
Pod položkou Results sa nastavíme na Reports a v okne Reports na Forces, Set Up... Otvorí sa okno 
Force Reports. 

 
Klikneme na Set Up.... Vo Wall Zones máme označené wall_ps aj wall_ss. V okne Direction Vector je 
v okne X číslo 1 a v okne Y 0. Klikneme na Print a zobrazia sa nám sily pôsobiace na profil v smere osi 
X. (Ak by sme klikli na tlačidlo Write... výsledky by sa nám zapísali do textového súboru). 
Program ANSYS Fluent vypíše výsledky v nasledovnom formáte. Forces – Direction Vector (1 0 0) 
označuje, že výsledky sú vyjadrené k smeru osi X, tj. ide o výsledky odporových síl. Prvé 3 stĺpce 
s výsledkami sú sily (v newtonoch)  - Forces (n). Pod stĺpcom Pressure sú výsledky tlakovej sily 
pôsobiacej na hornú a dolnú stranu profilu. Riadok Net označuje sumu. Pod stĺpcom Viscous sú 
výsledky trecej sily. Stĺpec Total je súčet tlakovej a trecej sily. Ďalšie 3 stĺpce sú výsledky koeficientov 
(tlakového, trecieho a celkového). Pre nás je dôležitá celková odporová sila s hodnotou 3,4775676 N 
a koeficient odporu 0,028388307.  
 
  

 
 

 
Obdobným spôsobom sa pozrieme na výsledky sily v smere osi Y, tj. vztlak.  V okne Direction Vector je 
v okne X číslo dáme 0 a v okne Y 1. Klikneme na Print. Celková vztlaková sila má hodnotou 0,015339669 
N a koeficient vztlaku 0,00012522179. 

 

 
 



 

 
Dosiahnuté výsledky sú logické. Vztlaková sila je veľmi malá a vzhľadom k tomu, že je obtekaný 
symetrický profil s uhlom nábehu 0°, tak vztlaková sila by mala byť veľmi blízka nule. 
V okne Force Reports je možné kliknúť na Moments a zistiť otáčavý moment ktorý vyvolá prúdiaci 
vzduch okolo profilu krídla. Je tu však potrebné zadefinovať súradnice x, y, voči ktorým chceme 
moment určiť. Ďalej sa pozrieme na priebeh tlakového koeficientu.  
Pod položkou Results sa nastavíme na Plots a v okne Plots na XY Plot, Set Up…. Otvorí sa okno Solution 
XY Plot.  V okne Surfaces máme označené wall_ps a wall_ss. V Plot Direction máme v okne X 1 a v okne 
Y 0. V roletovom menu Y Axis Function si pod Pressure vyberieme Pressure Coefficient.  
 
 

 
 

Klikneme na tlačidlo Axes... . Otvorí sa okno Axes – Solution XY Plot a v okne Axis sa prepneme na Y. 
V okne Number Format z roletového menu vyberieme general. Apply> Close> Plot.  

 
 

 
Zobrazí sa nasledovný priebeh. Výsledky tlakového koeficientu sa na tlakovej aj sacej strane prekrývajú, 
pretože tlakové pomery sú pri obtekaní symetrického profilu s  uhlom nábehu 0°rovnaké. Na nábehovej 
hrane (nábehovom bode) profilu je bod stagnácie. Je tam najvyšší tlak. Hodnota tlakového koeficientu 
je rovná 1. Hodnota tlaku za nábehovou hranou smerom k odtokovej hrane najprv klesá a prechádza 
do záporných hodnôt. A od pozície 0,07m od nábehovej hrany stúpa, stále však vyjadruje podtlak, až 
do vzdialenosti 0,4 m od nábehovej hrany. Čiže 10 cm pred odtokovou hranou je okolo profilu pretlak.  



 
 

 
Zobrazíme si distribúciu tlaku okolo profilu krídla pomocou izoplôch. Pod položkou Results sa 
nastavíme na Graphics and Animations a v okne Graphics na Contours, Set Up...  Zaškrtneme  
Filled a v položke Contours of ponecháme Pressure a Static Pressure. Klikneme na tlačidlo Display. 
Zobrazí sa nasledovný obrázok, ktorý vyjadruje to, čo sme videli na priebehu tlakového koeficientu.  

 
 

V prípade, že chceme jemnejšie prechody farieb, v okne Levels nastavíme vyššiu hodnotu ako 20, 
maximálne 100. Obdobným spôsobom môžeme zobraziť aj priebehy iných veličín okolo profilu, napr. 
rýchlosti. V položke Contours of vyberieme z roletového menu Velocity... a pod tým X Velocity. 

 
 

 



Ešte si zobrazíme vektory prúdenia okolo profilu nasledovným spôsobom. Pod položkou Results sa 
nastavíme na Graphics and Animations a v okne Graphics na Vectors, Set Up... , Display.  Po priblížení 
dostaneme nasledovný obrázok. Simuláciu si uložíme File>Write>Case&Data 

 
 

 
Simuláciu s prúdením s uhlom nábehu 10° riešime obdobne ako predchádzajúcu. Klikneme na 
Boundary Conditions>velocity inlet>Edit. Do okna X-Component of Flow Direction vpíšeme kosínus uhla 
nábehu. V našom prípade je uhol nábehu 10°, teda vpíšeme 0,9848078. Do okna Y-Component of Flow 
Direction vpíšeme sínus uhla nábehu. V našom prípade vpíšeme 0,1736452. OK. 

 
 

 
Ostatné nastavenia ponecháme z predchádzajúcej simulácie. Nastavíme sa na Solution Initialization 
a klikneme na tlačidlo Initialize. Ak sme predchádzajúcu simuláciu neuložili. Zobrazí sa otázka The 
current data has not been saved. Ok to discard? OK. Spustíme simuláciu. Run Calculation. Do okna 
Number of Iterations dáme napr. 1100 a klikneme na tlačidlo Calculate. Po ukončení výpočtu pod 
položkou Results sa nastavíme na Reports a v okne Reports na Forces, Set Up... Otvorí sa okno Force 
Reports. V okne Direction Vector je v okne X číslo 1 a v okne Y 0. Klikneme na Print a zobrazia sa nám 
sily pôsobiace na profil v smere osi X.  

 
 

 



Obdobným spôsobom sa pozrieme na výsledky sily v smere osi Y.  V okne Direction Vector je v okne X 
číslo dáme 0 a v okne Y 1. Klikneme na Print. 
 

 
 

 
Máme výsledky, ale treba mať na pamäti ako je definovaná odporová a  vztlaková sila. Odporová sila 
pôsobí, proti smeru prúdenia a vztlaková sila je kolmá na smer prúdenia. Lenže uvedené výsledky nám 
toto nezobrazujú. Sú to výsledky síl v smere osí X a Y, čiže z uvedených výsledkov vieme hodnoty 
axiálnej (A) a normálovej sily (N). Výsledky odporovej sily (D) a vztlakovej (L) si môžeme dopočítať, 
alebo vo Force Report, do okna Direction Vector pri smere X vpíšeme údaj ktorý sme zadávali pri 
velocity inlet, čiže 0,9848078 a do smeru Y 0,1736452. Print. Zobrazia sa výsledky odporovej sily 
a koeficient odporu.  

 
 

 
Do okna Direction Vector pri smere X vpíšeme -0,1736452 a do smeru Y 0,9848078. Print. Zobrazia sa 
výsledky vztlakovej sily a koeficient vztlaku. 

 
 

 
Tak ako v predchádzajúcom prípade, pozrieme na priebeh tlakového koeficientu. Pod položkou Results 
sa nastavíme na Plots a v okne Plots na XY Plot, Set Up…. Otvorí sa okno Solution XY Plot.  V okne 
Surfaces máme označené wall_ps a wall_ss. V Plot Direction máme v okne X 1 a v okne Y 0. V roletovom 
menu Y Axis Function si pod Pressure vyberieme Pressure Coefficient. Klikneme na tlačidlo Axes... . 
Otvorí sa okno Axes – Solution XY Plot a v okne Axis sa prepneme na Y. V okne Number Format 
z roletového menu vyberieme general. Apply> Close> Plot. Zobrazí sa nasledovný obrázok.  

 
 



Vieme z priebehu stanoviť to, že bod stagnácie, čiže miesto s najvyšším pôsobením tlaku je na tlakovej 
strane vo vzdialenosti 7 mm od nábehovej hrany (nábehového bodu)  v smere osi X. Od vzdialenosti 10 
cm od nábehovej hrany je tlak na tlakovej strane záporný a  smerom k odtokovej hrane sa blíži k nule. 
Na sacej strane ide priebeh do podtlaku. Podtlak sa najme posledných 10 cm blíži nule. Takýto priebeh 
tlakového koeficientu hovorí o tom, že úsek profilu pri odtokovej hrane nevyvíja vztlak.  
Z dôvodu vizualizácie si zobrazíme distribúciu tlaku okolo profilu. Pod položkou Results sa nastavíme 
na Graphics and Animations a v okne Graphics na Contours, Set Up...  Zaškrtneme  
Filled a v položke Contours of ponecháme Pressure a Static Pressure. Klikneme na tlačidlo Display. 
Zobrazí sa nasledovný obrázok. 

 
 

 
V položke Contours of vyberieme z roletového menu Velocity... a pod tým X Velocity.  

 
 

 
Tieto obrázky nám ukazujú, že nad sacou stranou pri odtokovej hrane je oblasť spätného prúdenia, 
teda separácie prúdu od profilu. To je aj vysvetlením prečo hodnoty tlakového koeficientu sú blízke 
nule. Pod položkou Results sa nastavíme na Graphics and Animations a v okne Graphics na Vectors, Set 
Up... , Display.  Po priblížení k odtokovej hrane profilu dostaneme nasledovný obrázok. 



 
Pod položkou Results sa nastavíme na Graphics and Animations a v okne Graphics na Contours, Set 
Up...Odškrtneme Filled a v položke Contours of dáme Velocity... a Stream Function. Klikneme na 
tlačidlo Display. Zobrazí sa nám obrázok, kde vidíme akým smerom prúdi na profil vzduch.  
 

 
 

 
My sa však chceme pozrieť na prúdenie okolo profilu detailnejšie, preto Levels nastavíme na 50 
a odškrtneme Auto Range. Do okien Min a Max dáme 168 a 173. Display.  

 
 

 

 
 



 
 

 
 


